Start a new topic
Solved

Waveform slider and time stop before track ends

Both, the waveform slider and the time, stop before the tracks finished playing.

mkv

Fixed.

 

works for me now


greets

Please retest with:

http://files.helium.fm/helium_0.5.523.0.exe


I made some tweaks with some different flags which solved this for me.

Tested further and I could force it to happen also, when not using WASAPI.

It seems to be some issue with BASS, the end-sync is triggered to early, I will raise this question in BASS forums to see if there are any reason why this happens.

I will test this further tomorrow. I'm away from my computer tonight.

yes is see all my files stopped 3sec before end

without Wasapi


greets

The file is correct, WASAPI works correct, but the slider and time are round about four seconds in front of the sound.

 

I can not reproduce

playing five files without problem


greets

Another test you can perform is to see if the normal position bar behaves the same (e.g. skipping before the file is finished).

Also, please share the file so that I can perform tests with it.

I sthe audio file correct?

I did some random tests and it works like it should.


If you enable WASAPI will it work then?

This also happens on a 3:15 minutes track, it's just harder to see...

The track has been played completely, I just cut the first 3 minutes in the video file.

I'm not using WASAPI right now.

mkv

This happen because of the extreme low scale on short files.

A larger buffer is allocated by BASS but it won't be filled to 100% in these situations, so no bug.

Login or Signup to post a comment