Start a new topic

SQL Server backup error: Microsoft.SqlServer.SqlClrProvider

When I try to backup a SQL database I get the following error:


Cann't load file or assembly

'Microsoft.SqlServer.SqlClrProvider, Version =, Culture = neutral,

PublicKeyToken = 89845dcd8080cc91' or one of its dependencies. The

system cann't find the file specified.

The backup will get to do with the templates and settings, but does not include the database.

I tried to fix it by installing these two SQL complements. Unsuccessfully:

- Microsoft SQL Server 2016 Shared Management Objects (SharedManagementObjects.msi)

- Microsoft System CLR Types for Microsoft SQL Server 2016 (SQLSysClrTypes.msi )

- Helium 12.0.14303.0

- Windows 10 Pro 64bits 14393.105

- SQL Server 2016 Express 13.0.1708.0

Thanks for your report Juan, we are currently trying to reproduce it and will let you know about our progress here.

1 person likes this

We have tried to reproduce this on three different machines with the following setups:

1) Win10 Pro x64, SQL Server Express 2016

2) Win10 Pro x64, SQL Server Express 2014 with 2016 addon

3) Win10 Pro x64, SQL Server Express 2014

Unfortunately we could not reproduce your exact case with any of these setups.

Therefore we would recommend you to contact us via the Customer center for further analysing of this issue.

What we did found on one of the machines during the test was that the UAC kicked in when the backup should be compressed and did not allowed it,

This is something we will correct for the next release.

Closed as system specific issue.

After several tests on various machines we were not able to reproduce this issue.

A workaround is to create a backup via SQL Server Management Studio.

1 person likes this
Login or Signup to post a comment