Start a new topic

Unable to change font size when running Helium 12 inside a VM

I'm unable to change the font size when running Helium 12 inside of a VM. I've tried many different operating systems, 2008 R2, 2012 R2 and Windows 10 and all get the same result. I have tested this on ESXi 5.5 and 6.0. All is fine when it is not running inside of a VM. 

When I try to change the font size the options dialog closes but I do not get the prompt telling me to restart Helium for changes to take effect. Even if I restart helium the default setting of Normal is still there. 

Is running Helium inside of a VM not supported?

I tested this against the official Helium 12 release and the latest beta 12.02. 


We generally not perform end-testing with Virtual machines, but generally all functions "should" work with a VM.

I just tested to change the font size to large with the new beta, 12.0.3, on a "standard" machine and that worked as it should.

The new setting is written to helium.json file when changed and were properly read (and set) after a restart.

According to your description, it sounds like the value might not be properly written to helium.json on your VM (access rights?).

After you have changed the property and Helium has closed, can you please check which value FontSizeChange has in helium.json?

(helium.json is located in C:\Users\YourUserName\AppData\Roaming\Imploded Software\Helium 12)

Closed, if you have more information please let us know and we will reopen it.

Login or Signup to post a comment