Start a new topic

Update Library problems

After hanging onto Helium 11 for a while I decided to give Helium 12 a try.

Installed Helium 12.4 with a Maria DB library. Maria DB resides on same machine as Helium 12, while the folders with the file are on a remote storage server. The library consists of 317320 tracks, 19000 albums, 33612 artists.

Attempts to update the library hang at step 4/8 - searching for new files. Following repeated attempts, once or twice managed to go to step 5 that gets stuck at 97% done.

Any words of wisdom?

Closed due to more information. If you still experience issues with the function, please contact us back.

Sorry for the delayed response. I did do a fresh import of all files and everything worked positively. Now, I'm poking around and getting a feel of how Helium 12 performs.  

Yes, this issue has been addressed. Thank you.

Thanks for the update Lazarus, great to hear that it works now.

Hello Lazarus,

Do you have any updates on this possible issue?


Hard to say an exact reason, but have you checked your connection settings so that the MariaDb does not timeout?

It might also relate to a specific file that's problematic, hence reading will be slow or hang.

Is your library imported from an earlier Helium version or created with Helium 12?

If you need in detail help, you can activate extended logging, perform the update (clear the logs folder first) and then open a support ticket at together with the logs so that we can analyse it in detail.

Made sure MariaDB settings conform to recommendation listed here:

That being said, checked for values on MySQL site for wait_timeout -- adjusted as such, since the default value for Windows installations is much higher than the recommended listed on Imploded site ( Imploded = 7000 / MySQL = 28800 ) []

Didn't improve things. Still hangs.

Yes, the library was imported from Helium 11 - it took between 36-48 hours to complete the import.

In terms of specific file causing the problem... It's highly improbable, since it exhibits the same problem when trying to update distinctly different directories that contain distinctly different files.

The next step will be to start by importing to a fresh library. Let's see how that goes.

>>The next step will be to start by importing to a fresh library. Let's see how that goes.

Please try that. Id you experience any specific issues that you need help with in detail, please take contact with our support at

I suspect it might relate to a specific file as earlier mentioned, logs can help us to answer that.

Login or Signup to post a comment