Start a new topic

Saving Comments

It appears that editing and saving comment tags does not work as expected.

Specifically, in the tag editor, it does not save comments when deleting previously entries and leaving field blank.

Quick editor seems to perform as expected, while Advanced tag editor seems to be unreliable. Sometimes it saves, sometimes it doesn't...

We have tried to reproduce this as good as we could with the given information, but during our tests it worked like it should.

The tests were performed like this:

1) Took a file without comments

2) Tagged it with the Advanced tag editor, applied a comment

3) Checked via Properties that the tag was properly saved

4) Repeated steps 2-3 two more times

The tests was performed with five different MP3 files, five different FLAC files and three different Ogg files.

As you describe it, it might be related to either specific existing tag data on your files and/or a specific file type.

Do you have a pattern that can be reproduced with one or more specific files?

As I mentioned earlier, Advanced tag editor works (once in a while). Try deleting the comment data of one track in tag editor (the comment is now blank), then apply to all tracks in the album and save.

We have tested this scenario also and it works just as it should when we tested with FLAC and MP3 files.

The only thing I can think of is that if you are using MP3 files which contains either TXXX tag-frames and/or COMM tag-frames which contains data that are only read but not written due to compatibility reasons.

Which file type does this relates to?

Can you share one or more sample files?

It's with MP3 files.. The only way I can get around this is by using third party software to modify/update the comment field.

I will try and share a file or two - when I come across the next one....

Thanks in advance. 

Also, can you please let us know if you are working with the single-line comment field or multiple comments?

Closed since no further information was received. If the issue still appears, please open a support ticket at:

Login or Signup to post a comment