Start a new topic

Can't use streamer on android


Im having problems with the Helium Streamer. I just bought both of the premium softwares. I enabled the web services in manager and I typed the correct address and port in the helium app but it didnt work. The app says "Settings_PremiumErrorStreamer". The instructions online are confusing. I dont know what to do.

A.T., your latest customer


In order to use Helium Streamer on Android you need to purchase a license of Helium Streamer. The web service in Helium is only used for remote controlling the application using the Helium Remote app.


Fredrik Heidgert

Imploded Software

I already purchased the license. I have no Idea what to do.

If you start the Helium Streamer Launcher you will see some addresses.

If your phone is connected to your home Wi-Fi you can enter the IP-address under the App access / Address on LAN label in the Helium Streamer app on your phone and you should be connected.

Please let us know if you have any trouble doing this.

I have tried to do exactly as you told but I still get the error message. Should I make a setup in the Manager or something before trying to connect?

If Helium Streamer works in the web browser you should be good to go.

Can you browse to Helium Streamer? What version of Helium Streamer is displayed on the Settings > Advanced page?

I think the problem was because I hadn't set up the password. The address on LAN works now but over the Internet it doesn't. I can open it in my desktop browser but not in the app.

If you are on the same network you should be able to connect using the IP address provided in the Streamer Launcher application. What happens when trying to connect from the app?

I have exactly the same problem. It works with the web interface but not with the app. I bought the licenseand activated the it. I used the adcress shown in the Streamer Launch application. But I am not able to connect Always get the message 'Settings_PremiumErrorStreamer'

Let us check on this and we'll get back shortly!

I restarted the launcher after activating the key and now it works.

Glad to hear you got it working!

Login or Signup to post a comment