Start a new topic
Solved

No Sound

Helium 13 build 14958

Something strange - I have no sound.

If  I start foobar 2000 as a player sound is there.


Hello,


Are you using WASPI or DirectSound?

Have you checked that a valid audio device is selected in options? (Tip: try to change between available devices)


1 person likes this
Thanks. That's it.
I'm a excited HMM 11-User. With the change from Windows 7 to Windows 10 and the change from HMM 11 to 12 and now 13 at the same time I'm not so happy.

 

Good to hear that it got resolved.

If you have some issues that related to Helium 13, please let us know, the migration Windows 7 > 10 is unfortunately nothing we can assist with.

I had some confusion (no sound?)  with 14.3.16274.0
Read this post and switched the output device.
Don't know what the WASPI thing is, but it didn't seem intuitive that the DEFAULT wouldn't be to use whatever the active Windows sound device was currently.

So, does that mean that if I change the sound device using my Windows taskbar volume icon that I also have to manually change it using Helium preferences?  
That isn't the way other applications work...

Ben, if you change to DirectSound (software mixer) will it help ? 


Wow, fast developer response!
I just bought Helium Premium a few days ago, so far I am loving it.

It has so many options and features that it is taking me a while to figure it out.

The audio output worked yesterday when I switched the "Helium-->Tools-->Options-->Player-->Output Device"  to my Monitor (where my headphones are plugged in).  The windows taskbar volume icon already indicated that output was my monitor.  Which is why I was confused, windows sounds were working but Helium wasn't, even after I restarted it.

What I would like is for the software to have a setting that just says "Use whatever Windows is set to use".

I connect from RDP sometimes, and sometimes I have my headphones locally and sometimes I use speakers locally.  Windows automatically switches to different devices with no action required from me.


I hope that I don't have to keep changing the Options menu of Helium.


Hi Ben,


Try to disable WASAPI from:

Tools > Options > Player > Use WASAPI (uncheck this)


When unchecked, set Output device to Default.


This seems to worked well during my tests, BUT, Windows 10 kept "stealing" my playback device in some scenarios.

That could be seen via Windows volume mixer which muted multiple running apps.


To prevent that, I followed these steps:

https://audible.custhelp.com/app/answers/detail/a_id/9463/~/how-do-i-turn-off-exclusive-mode-for-a-windows-audio-playback-device%3F 



Login or Signup to post a comment