Start a new topic

Set Release Type Not Working in Releases view

If I select an album in releases view, right click and attempt to change release type from Undefined to album (let's say), I get a notification tagging complete but no changes are made.

There are errors in the extended log attached.

The album consists of .mp3 files. I have the latest Helium 14.1 and it is running on Windows 10 Pro 64bit version 1803


Have just checked using the tag function and it is set to album on each of the files but the album display still has UNDEFINED overlaying the album picture.

Just tried some other operations on a different album - changed to Live Performance from Undefined - tags show this correctly but releases view doesn't. During the tagging operation, the screen "breathed" getting larger and then returning to normal. Tagging operation reported as successful. After updating, it used a different album picture (one saved to tags instead of the one I had assigned to it in Helium). I cleared the picture and then changed it selecting the preferred one from the file folder containing the tracks which Helium had opened. However, as a result, two other albums already marked as Live Performance and using the same picture (albeit with a different filename) have disappeared from the database..

I attach a further extended log file.

I am starting to wonder if the database (migrated from Helium 13) is corrupt.



We have tried to reproduce this issue, but it seems to work as it should.

Therefore we suspect that it most likely database and/or file related.

For further assistance, please open a supportcase at for further assistance in this case.

Login or Signup to post a comment