Helium 12.0.5 beta now available (build 12.0.14356)

1 person likes this

If anyone got a message about an invalid database with this version, please update to build 14357 (available via the update checker) to see if it helps.

Also, try to reopen a previously created database which got reported as invalid with build 14357 to see if will open OK.

If error message about missing tables are shown, please contact our support.

.... but now  when I am editing and saving track changes

a) HMM tries to save the changes but doesn't come to an end
b) or crashes, when clicking OK again
c) or comes up with error messages


@Erwin: Does this happen with your old or new database? If you create a new database with, can you reproduce the problem? We had no luck in reproducing this issue so we need more reproduction details to assist you further. Possibly you should open a ticket since this is most likely database/setup related.
It happens with the database created with build 14356 (and data imported from the previous build).

Currently I am creating a new database with build 14357 and import the the data again. It takes a while


Please note that you can try to open your old database, created before build 14356, as mentioned in the announcement.
hmmm, strange

a) when using the newly created database HMM gets a nervous breakdown again showing an error during the update of "natalia imbruglia". But all I did was editing one ablum fom 10.000 maniacs. Strange
b) opening the old database (used with the build 14359) now with build 14357 it works

i.e. don't use build 14356 in any way, even not for importing data ;-)

OK, works again. As well the import of files - which hang up in 14356 - works again

Let's continue


crashed on start :(

Did you tried to delete json files (there is a later release which should fix this)? Please see the bug reports for a link to the later release..

i read it and json delete not solved problem :(

Then please open a ticket and let us know which exact error message and database type you are using so that we can assist you further.

1 person likes this

Good update and so far everything is working for me. Just a couple random cosmetic things:

1. With font size set to large (Options/Visual/Font-size) the bottom line under albums in clipped in half (see attached) and when I go to the update library window the 'select none' button has the 'e' at the end clipped off and the 'housekeep' button has part of the 'p' clipped off.

2. Also in the update library window--- it doesn't remember its size like most other windows do. Every time I go to update library it's a smallish box even after I stretch it, close the window, and come back.

(236 KB)

Thanks for the feedback Walt.

We will review these two things for our next release.

Login or Signup to post a comment