Start a new topic

MariaDB buffer size

I followed the config guide and added a line to my.ini to set the buffer size to 1017M and restarted my whole system. I still continue to be told when starting HMM that the buffer size is too small although all the other settings seemed to have worked ok. I can see from the log that the size is being set correctly so I ma guessing the size should actually be bigger than 1017M. Any suggestion as to what value to try next?

Best Answer

1023M seemed to work. I will stick with that.

MariaDb can mix configurations from various places so just editing my.ini might not always help.

You can check the actual variables by executing the SHOW VARIABLES command (against the database engine) and review the results of the actual used values.

Another way is to check Helium's logs which dumps the results from SHOW VARIABLES.

If you need further in-detail assistance you can take contact with our support:


1023M seemed to work. I will stick with that.

Great, feel free to contact us for more in detail assistance.

Just to let you know that despite 1017M worked for me using MariaDB 10.3 on a NAS, the line "innodb_log_buffer_size=800M" does not work at all (including changing to 500M).

MariaDB does not start if I include that line in my.cnf.

So I just left it out.

Please note that settings depends on the backend hardware, a NAS has generally more limited capabilities compared to a "standard" server setup. 

Login or Signup to post a comment