Start a new topic

Certain characters cause the field to be cut from that character.

What I've found is that when I have one of the following characters in most fields:

  • IDEOGRAPHIC SPACE (U+3000) " "
  • FOR ALL (U+2200) "∀"
The field gets truncated to before that character.
Tested on FLAC and MP3 in Helium 13.0.14958.0 on Windows 10.

Added some images of me trying to tag the album name.
The value is: "∀ GUNDAM オリジナル・サウンドトラック"
  1. I've pasted the value into the album field.
  2. I've hit "Save changes" and the value appears in the list for a bit.
  3. The value get's truncated to nothing after a second or two.

I tried it out for a bit to figure out what's wrong, first I suspected that it might be a limitation in Unicode support so I tried out some newer characters and they worked just fine. (Like the 'PILE OF POO' (U+1F4A9) "" character for example.)

Then i noticed that if i had text before either a "∀" or " " the value was truncated to before that character. So I have no clue what's going on, is this a limitation in SQL Server CE or a bug in Helium 13? I think I've been able to have " " characters in versions before 12.

(56.2 KB)
(64.8 KB)
(60.9 KB)


This is not any known limitation.

Do you have the possibility to test this on another database than SQL Server Compact?

Yes, I can test it out with MariaDB and/or MySQL. Will report back when done.

Closed for now, no further reproduction details received. If this issue can be reproduced , please open a support ticket for it.

Login or Signup to post a comment