Start a new topic
Solved

Player plays second of the previous song after pause

Version 14.0.16119.0


Steps for Reproduction


  • Start playing some song
  • Pause the player
  • Start playing another song (for example by double click in the list)
  • !!! Player begins to play with about a second of previously paused song.

Maybe it have something with buffer, that is not cleared on starting another song after pause.

Expected Behaviour

Playing only the new song without something of the previous one after pause.

Thanks for the information Mikael.


For me the solution was DirectSound.

>> Should I expect any problems by disabling of WASAPI? 

No. WASAPI (Windows Audio Session API) is Microsofts hardware interface which works directly against sound devices using the providers unique drivers.

Simplified, when active in Helium, Helium will work as a bridge when playing music - just forwarding data to WASAPI which is responsible to pick and use the proper replaying routines.


When DirectSound is used, playback will be handled within Helium using a software mixer. (Using DirectSound's replaying engine)


For more specific WASAPI details, please google it.


1 person likes this

My Screnshots are not visible in the last post. I will try it again. In the previous post they were somehow inserted twice (Ctrl+V), so I had removed the second inserted one but it looks like it remove all them. Strange behaviour of the posting text editor.


#1 Options at the reporting time


image


#2 Options, that solved my problem


image



Settings of the player should not be changed after installation:



Soundcard: Realtek High Definition Audio.

Driver Provider: Realtek Semiconductor Corp.

Driver Version: 6.0.1.7786


All Effects for the device are disabled.

Output Quality: 24 Bit, 192000 Hz


Installed: Sound Blaster X-Fi MB5 Version 1.00.11


Using build in speakers of the notebook.


OS: Windows 10 Pro 1703



Disabling of WASAPI solved my problem:


Should I expect any problems by disabling of WASAPI?

This can depend on your machine's specific drivers and player settings.

Some additional details are needed here:


-Do you use WASAPI or DirectSound?

-Which buffer settings do you have in Helium?

-Which soundcard do you use and which OS are are you using?

Login or Signup to post a comment